// Преобразовывает таблицу значений в массив структур
 &НаСервере Функция ПреобразоватьТаблицуВМассив(ТаблицаЗначений) Экспорт Перем РезультатМассив; Перем СтруктураСтрока; // Сформируем массив структур
 

    РезультатМассив = Новый Массив;
    Для Каждого Строка Из ТаблицаЗначений Цикл
        // Сформируем структуру-строку
         СтруктураСтрока = Новый Структура;
        Для Каждого Колонка Из ТаблицаЗначений.Колонки Цикл
            СтруктураСтрока.Вставить(Колонка.Имя, Строка[Колонка.Имя]);
        КонецЦикла;
        РезультатМассив.Добавить(СтруктураСтрока);
    КонецЦикла;

    Возврат РезультатМассив;

КонецФункции

далее работать с массивом значений на клиенте.

еще код


%MINIFYHTML3e810914cff7e9c321079b6eb69a08c613%
&НаСервере
Функция ЗаполнитьМагазины()
 Массив = Новый Массив;
 Структура = Новый Структура("НомерМагазина","НомерМагазина","НаименованиеВСАП","ТорговаяПлощадь","ДатаОткрытия","Комп","ТипМагазина","Регион");
 й = 0;
 Для Каждого Стр Из Т Цикл
 Структура.Вставить("ГУИД",Стр.ГУИД);
 Структура.Вставить("НомерМагазина",Стр.НомерМагазина);
 Структура.Вставить("НаименованиеВСАП",Стр.НаименованиеВСАП);
 Структура.Вставить("ТорговаяПлощадь",Стр.ТорговаяПлощадь);
 Структура.Вставить("ДатаОткрытия",Стр.ДатаОткрытия);
 Структура.Вставить("Комп",Стр.Комп);
 Структура.Вставить("ТипМагазина",Стр.ТипМагазина);
 Структура.Вставить("Регион",Стр.Регион);
 Массив.Вставить(й,Структура);
 й = й +1;
 КонецЦикла;
 Возврат Массив;
КонецФункции


&НаКлиенте
Процедура ПрочитатьДанные(Команда)
 Магазины.Очистить();
 Массив = ЗаполнитьМагазины();
 й=0;
 Для Каждого Стр Из Массив Цикл
 Структура = Массив.Получить(й);
 й=й+1;
 НС = Магазины.Добавить();
 НС.ГУИД = Структура.ГУИД;
 НС.НомерМагазина = Структура.НомерМагазина;
 НС.НаименованиеВСАП = Структура.НаименованиеВСАП;
 НС.ТорговаяПлощадь = Структура.ТорговаяПлощадь;
 НС.ДатаОткрытия = Структура.ДатаОткрытия;
 НС.Комп = Структура.Комп;
 НС.ТипМагазина = Структура.ТипМагазина;
 НС.Регион = Структура.Регион;
 КонецЦикла;
КонецПроцедуры



/1s/peredacha-tablitsi-znacheniy-s-servera-na-klient.html