Подробнее: vitalwatch

vitalwatch - watch face for Sony Smartwatch 3

Подробнее: Aikido manual

Aikido manual - развивающаяся и дополняющаяся программа с описанием техник, терминов. Планируются краткие справочные видео, форум, также возможность закачивать видео и фото пользователями.

Мобильное приложение позволит быстро подсмотреть необходимые материалы или пообщаться в сети с другими людьми. Самая важная и необходимая информация сжата и упакована в вашем мобильном устройстве.

Чтобы получить новые дополнения и информацию, пожалуйста оставляйте пожелания!

c#-xamarin

Подробнее: FAQ по серверам 1C.Клиент-серверная версия Рисунок трехступенчатой ​​структуры (так называемые "trehzvenka»), которая включает в себя: клиент, сервер и сервер базы данных 1С. Это совершенно отдельный компонент, которые могут быть объединены для достижения наилучших результатов в любых допустимых комбинации. Рассмотрим следующую схему:

Давайте начнем с клиентом является текущей версией платформы (8,2), использование трех типов клиентов. Давайте рассмотрим их подробнее.

Жир клиента. Это классический 1С клиента, выше на 8,2 платформа была единственным доступным видом клиента. Схема толстого клиента выглядит следующим образом: клиентское приложение запрашивает данные с сервера 1С свою очередь, называет их из базы данных, и сделать его обратно к клиенту, где они обрабатываются и производится.

Как вы можете видеть, эта схема не является оптимальной: сервер 1С сути, это просто слой между клиентом и базой данных, все расчеты на клиенте. Это предъявляет высокие требования к клиентскому ПК, такие как вычислительная мощность сервера не используется. Это должно быть ясно, что в режиме толстого клиента, вы не получите увеличение bystrodeystiviya от перехода к клиент-серверной версии, возможно, даже наоборот.

Подробнее: Мультибазовый отчет СКДМультибазовый отчет СКД - гибкая система получения данных с физически разных но одинаковых по запрашиваемым данным баз. Например из баз в разных филиалах при наличии доступа к сам базам или из Бухгалтерии, УТ и ЗИК одновременно. Сбор и отображение отчетности из разных баз и возможно даже конфигураций с одинаковыми частями учета.

Этот отчет предназначен для программистов. Он наглядно может представить принцип создания отчета СКД по COM соединению, и созданию запросов на стороне сервера. По сути это шаблон СКД отчета, основанного на COM соединении на стороне сервера, может служить для программистов основой для создания своего отчета из нескольких баз. В отчете есть возможность задавать как отдельные данные для каждой базы, так и задавать на форме общие параметры, такие как дата  или период. В этом шаблоне проверены схемы работы в режиме мультиотчета, поэтому шаблон предлагает один иV82.COMConnector, COMОбъект,  Automation - сервер.

 

Функция добавления

Функция  ДобавитьНули(Значение, НужнаяДлинаЗначения)
 
 Значение  = СтрЗаменить(Формат(Значение, "ЧГ="), " ", "");
 НадоНулей =  НужнаяДлинаЗначения - СтрДлина(Значение);
 ВедущиеНули =  Формат(0,"ЧЦ="+НадоНулей+";ЧН=; ЧВН=; ЧГ=0");
 Возврат ВедущиеНули  + Значение;
 
КонецФункции

 

'Перед работой необходимо импортировать пространство имен System.IO:

Imports System.IO'

Как создать новый файл?

Передача файла на сервер 1с.

&НаКлиенте
Функция ПередатьФайлНаСервер(Путь)
Файл = Новый Файл(Путь);
ФайлИсточник = Файл.ПолноеИмя;
Адрес = ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(ФайлИсточник));
Возврат(Адрес);
КонецФункции // ПередатьНаСервер()

 

Чтение DBF

ФайлВВР = Новый XBase;
ФайлВВР.ОткрытьФайл("с:\staff.dbf",Истина); //только для чтения 
ФайлВВР.Первая();
ТЗ = Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить(...);
//создание колонок 
Пока НЕ ФайлВВР.ВКонце() Цикл
 Нов = ТЗ.Добавить();
 Нов.Наименование = ФайлВВР.Name;
 //заполнение полей 
 ФайлВВР.Следующая();
КонецЦикла,
ФайлВВР.ЗакрытьФайл();

 

Вычисление хеша файла.

В данном случае выполняется стандартная для всех версий Windows команда ping на IP-адрес, ответа от которого не будет и выставляется время ожидания отклика в секундах.
В данном примере задержка составляет 5 секунд.

 

 

пример коммандного файла, формирующего переменные для года, месяца, дня недели и пр.:

Множество примеров работы с почтой и в конце теоретические основы.

Почта = Новый Почта;
Почта.Подключиться();
Письмо = Новый ПочтовоеСообщение;
Письмо.Получатели.Добавить("хххх@хххх.хх");
Письмо.Тема = "Автоматическое";
Письмо.Текст = "АААА";
Письмо.Вложения.Добавить("C:\test1.txt");
Почта.Послать(Письмо);
Почта.Отключиться();

Функция СобратьМассивВСтроку(МассивСтрок, Разделитель = ";") Экспорт
 МассивСтрок= Новый Массив;
 кол=МассивСтрок.Количество();
 ОбщааяСтрока="";
 Для Инд=0 по кол Цикл 
 ОбщааяСтрока=ОбщааяСтрока+Разделитель+МассивСтрок.Получить(Инд);
 КонецЦикла;
 Возврат(ОбщааяСтрока);
КонецФункции

 

// Работа 1C с FTP (8.0,8.1,8.2)

// Загрузка файлов на FTP сервер
Процедура ЗагрузитьОтмеченные(Кнопка)
Сервер = Новый FTPСоединение(FTPServer);
Для Каждого Файл Из ПолеСписка Цикл
Если Файл.Пометка Тогда
Сервер.Получить(Файл.Значение.ПолноеИмя, "с:\temp" + Файл.Значение.ПолноеИмя);
Файл.Пометка = Ложь;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

НАЧАЛОПЕРИОДА(<Дата>, <Период>)

КОНЕЦПЕРИОДА(<Дата>, <Период>)

<Дата> - тип дата, берется для расчета периода.

<Период> - тип константа, период расчета, значения конца или начала этого периода. Значения:день,месяц,год,квартал,неделя

Пример: между началопериода(&ДатаНач,месяц) и конецпериода(&ДатаКон,месяц)

Пример: между началопериода(&ДатаНач,месяц) и конецпериода(добавитькдате(&ДатаНач, месяц, 1))

выбрать
ссылка
из документ.реализациятоваров
где ссылка.дата между началопериода(&ДатаНач,месяц) и конецпериода(датавремя(2006,3,30),месяц)

 
Был замечен случай когда на данном компьютере пользователя в рабочей базе была старая конфигурация, хотя на любом другом ПК и на сервере она обновилась. В таком случае поможет очистка кеша 1С 8.2 в каталоге пользователя %userprofile%\Local settings\Application data\1C\1Cv82\. Известные программы очистки диска обходят этот каталог стороной.

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)        
Табл = Новый ТаблицаЗначений;
Табл.Колонки.Добавить("Абонент", Новый ОписаниеТипов(Справочники.ТипВсеСсылки().Типы()));
Табл.Колонки.Добавить("ЛицевойСчет", Новый ОписаниеТипов("Строка"));
Табл.Колонки.Добавить("Период", Новый ОписаниеТипов("Строка"));
// тут строчка чтобы не отвкывали карточку обьекта

Как добавить запись в непериодический независимый регистр сведений?

НаборЗаписей = РегистрыСведений.ЗначенияСвойств.СоздатьНаборЗаписей();

 НаборЗаписей.Отбор.Номенклатура.Установить(ТекущаяНоменклатура); 
 НаборЗаписей.Отбор.Свойство.Установить(ТекущееСвойство); 

 НоваяЗапись = НаборЗаписей.Добавить(); 
 НоваяЗапись. Номенклатура = ТекущаяНоменклатура; 
 НоваяЗапись.Свойство = ТекущееСвойство; 
 НоваяЗапись.Значение = ТекущееЗначение;
НаборЗаписей.Записать();

// минимальный набор для описания внешней обработки или отчета
//&НаКлиенте
Функция СведенияОВнешнейОбработке() Экспорт

РегистрационныеДанные = Новый Структура;

РегистрационныеДанные.Вставить("Наименование", " ");

РегистрационныеДанные.Вставить("БезопасныйРежим", Истина);

// Преобразовывает таблицу значений в массив структур
 &НаСервере Функция ПреобразоватьТаблицуВМассив(ТаблицаЗначений) Экспорт Перем РезультатМассив; Перем СтруктураСтрока; // Сформируем массив структур


Программные продукты Фирмы «1С» в большинстве случаев защищены от копирования с помощью аппаратных LPT или USB ключей защиты типа HASP от фирмы Aladdin. Система лицензирования программ линейки 1С:Предприятие 8.* дает пользователям более гибкие возможности масштабирования при увеличении количества пользователей, наращивании вычислительных мощностей информационных систем, росте компании и т.д., но при этом у клиента может оказаться сразу несколько ключей от различных лицензий и версий программ 1С, внешне очень похожих, что может вызвать определенные затруднения.

Причем, довольно часто, в интернете встречается неполная и взаимопротиворечащая информация.

Данная статья должна помочь окончательно расставить точки над «i» и помочь при идентификации ключей от программных продуктов «1С».